最新消息:XAMPP默认安装之后是很不安全的,我们只需要点击左方菜单的 "安全"选项,按照向导操作即可完成安全设置。

“错误信息:php执行超时导致WordPress升级失败”

XAMPP教程 中文小张 807浏览 0评论

近日,WordPress释出了全新的5.0版,喜欢尝鲜的我自然会小试一把。

首先进入网站后台,发现有新版本提示,恩,不错,直接提示了可以升级至5.0版。

然后开始升级,大约等了一分钟左右,网站直接进入500错误。

Why?

可能原因

首先到临时目录(C:\Windows\Temp)查看,发现wordpress5.0的安装包已经下载了,但和正式版本相比,文件大小少了一些。

推测是因为php没有下载完安装包就中止了。

在php.ini中,有一个配置可以设定php最大执行时间,我设置的是60秒。如果php脚本执行时间过长,比如在下载/上传一个大型文件时,有可能超过这个值,导致脚本中止执行。

解决方法

我们修改php.ini中的max_execution_time和max_input_time为5分钟,如下所示:

max_execution_time = 600

max_input_time = 600

注意,修改以上两个参数后,需要重启IIS才能生效。

再次执行Wordpress升级,虽然页面提示有500的错误,但是再次刷新网站后台,可以看到新版本已经成功安装了。

转载请注明:XAMPP中文组官网 » “错误信息:php执行超时导致WordPress升级失败”

您必须 登录 才能发表评论!